Lançamento WHMCS v7.1 Estável

Foi anunciado hoje através do blog oficial o WHMCS na versão v7.1 (estável), em 16/11 foi divulgado a versão beta  e em 30/11 foi lançada a versão candidata. Os destaques (confira demonstração) do WHMCS v7.1 são: “novo” painel administrativo, suporte para domínios premium, melhorias de desempenho, diversas correções no sistema e etc.

Atualização

Se você possui o WHMCS v7 a atualização ocorrerá em 3 cliques, menu Utilitários >> Atualização e botão Atualizar* conforme imagem abaixo:

* O processo de atualização é o mesmo de sempre, antes de efetuar a atualização tire um backup ( arquivos + base de dados )…

Caso opte por instalar “manualmente” visite o link http://download.whmcs.com/ e siga as instruções do fabricante ou pegue o link (requer login).

Para evitar arquivos corrompidos sugiro que envie o arquivo compactado e efetue a descompactação no diretório do seu WHMCS, em seguida acesse http://seuwhmcs/install/install.php e siga o passo-a-passo.

Se você precisar de uma “mãozinha” podemos te ajudar http://atualizawhmcs.edvan.com.br/

Como já estava utilizando a versão candidata no meu WHMCS de desenvolvimento utilizei a atualização automática que levou em torno de 3 minutos.

Nas notas da versão é possível obter outras informações, no changelog está listado as modificações e melhorias, segue total (BetaCandidata e Estável ).

  • 12 novas implementações;
  • 83 correções de bugs/falhas no sistema;
  • 13 correções… nos módulos;
  • 4 correções na API;
  • 12 Atualizações nas traduções do sistema;

Alterações de templates podem ser verificadas neste link e formulário padrão de pedido (standardcart) aqui.

Quem utiliza nosso produtos/serviços não existem problemas de compatibilidade.

Gostou? Comente!

Atualização 21/12/2016

O Elison (leitor do blog) relatou um bug e compartilhou a solução obtida diretamente com a WHMCS.

Efetue o download do arquivo CORE-10723 em seguida envie os arquivos para pasta de instalação do seu WHMCS.

Fique atento a pasta “admin” em seu sistema.

Edvan

Proprietário da Edvan.com.br, referência em WHMCS no Brasil através de consultorias e desenvolvimento de produtos/serviços para WHMCS.

You may also like...

  • Edvan, você notou que o campo Servidor na aba produtos/serviços esta ficando setado o 1 servidor da lista e não o servidor correto do produto. tipo eu tenho 3 servidores de hospedagem todos os meus clientes estão sendo mostrado no campo servido como se eles estivem todos no mesmo server.

    • Manda um screenshot aí.

    • Que estranho fiz um teste aqui e não tive esse problema.

      Reporta a WHMCS.com ( https://www.whmcs.com/members/bugreport.php )

      • Dr. veja o que eles falaram.

        Hey Francisco Elison ,

        I have also been able to replicate this on my local install as well.

        As such, I have opened a case with our Developers for further investigation and review:

        CaseID: CORE-10723

        Our development team should review the case shortly and provide us with further steps for addressing your issue.

        We should be in contact when we have further information.

        Currently this is only affecting the UX (UserInterface) and does not effect the actual data handling, meaning that the server you select in the drop down, that serverID is saved in the database for that product.

        If you have any further questions/issues, please let me know.

        Thanks!

        • Bug na interface, certamente será corrigido bem rápido.

        • sim sim, ja me mandaram aqui os arquivas pra upa no sever, eu upei e deu certinho eles estão bem rápido agora kkkk

        • Maravilha!

          Depois me envie os arquivos assim disponibilizo aqui no blog.

  • Brinsley P. Aragão

    Olá camarada, uma pergunta de informação sobre esse update. Em meu caso foi noticiado pra mim que os arquivos:

    templates/orderforms/modern/viewcart.tpl
    templates/six/clientareainvoices.tpl
    templates/six/clientregister.tpl
    templates/six/img/logo.png
    templates/six/includes/head.tpl

    Estao personalizados e perderiam essa personalização, tenho as copias, se eu sobrepor terá algum problema com relação a “compatibilidade e correções” ou ficara tudo OK ?

    • Se sobrepor você perderá as personalizações.

      A solução é você refazer através dos arquivos originais do v7.1

  • Mauricio Castro

    Estou tendo problemas com esta versão em 3 licenças e dominios diferentes. Ao selecionar o cliente, clicando em produtos do cliente. O select que deve informar o servidor onde o cliente esta, informa o primeiro servidor da lista no banco de dados e não o servidor correto do cliente. Verificando no banco em tblhosting o registro esta salvo corretamente, mas informa errado. O grande problema é que se executar qualquer ação que chame um salvar automático irá mudar o servidor causando um grande transtorno.

    Instalei uma zerada para testar e o mesmo ocorreu em uma instalação limpa.

    Alguém mais notou isso ?

    • Já foi lançado uma correção para esse problema.

      Recebi mas esqueci de disponibilizar aqui no blog.

      • Mauricio Castro

        Obrigado pela info, este release de correção esta publicado ? pois não vi no site deles? Abs

        • Entre em contato com o suporte oficial e solicite os arquivos para correção do “CaseID: CORE-10723”.

          Até 17h devo disponibilizar esse arquivos aqui no blog.

        • Disponibilizei aqui no blog ou no link https://www.whmcs.blog.br/download/core-10723/

        • Mauricio Castro

          Obrigado por compartilhar Edvan, resolvido com sua ajuda.

        • Disponha!

    • Entre em contato com o suporte oficial e solicite os arquivos para correção do “CaseID: CORE-10723”.

  • Olá Edvan. Após a atualização não aparecem nenhum widget na tela de administração. Nem a lateral com os atalhos aparecem. Sabe o que pode ser?

    • Pode ser N fatores:

      Permissões do usuário, arquivos widgets ausentes e etc…

      • Mais os arquivos e as permissões anteriormente estavam ok. Dei uma olhada nas permissões antes e pareceram normais. Vou verificar mais e abrir chamado na WHMCS. Qualquer coisa dou um feed.

        • Os widgets nativos não utilizam mais permissões individuais por exemplo http://prntscr.com/dpaog7 agora são controladas pelas permissões globais http://prntscr.com/dpaool (marque todas e faça um teste).

        • Sinistro. No meu não aparece nenhum widget. Olha http://prnt.sc/dpb3ln

        • Verifique se a pasta /modules/widgets/ estão com os arquivos.

        • Vi os arquivos, mais para reforçar baixei o 7.1 e joguei novamente os arquivos no diretório. Ainda aparece o problema. Abri chamado com o whmcs.

          Alguma ideia?

        • Edvan, percebi que o problema só aparece no template V4. Usando o blend você vê a página administrativa normalmente com os novos widgets. Interessante que para acessar algumas páginas como a de configurações gerais e a de funções administrativas no modelo V4 pede senha, porém no blend acessa direto.

        • Esse template foi descontinuado… utilize o blend.

        • Que pena, obrigado EDVAN. valeu.

        • Sinceramente achei ótimo, o v4 era péssimo.

        • Kkk. Eu só usava o V4. Agora corrigiram o problema com a atualização para o 7.1.

        • Blz

  • wendell Costa

    meu dashboard esta em branco depois que fiz essa correção do bug do display CORE-10723, alguma coisa que precisa ser feita?

    • Essa correção não tem relação com esse problema.

      Sugiro que limpe o cache do navegador + WHMCS e se persistir entre em contato com suporte oficial.

  • [email protected]

    Good Morning,

    I’m trying to update but this is giving the following message

    Fatal error: The file /home/wooxtic/public_html/financeiro/install/index.php cannot be decoded
    by this version of the ionCube Loader.
    If you are the administrator of this site
    then please install the latest version of the ionCube Loader.
    in Unknown on line 0

    Can someone help me fix it?

  • [email protected]

    Bom Dia,

    Estou tentando atualizar, mas isso está dando a seguinte mensagem

    Fatal error: The file /home/wooxtic/public_html/financeiro/Ricardo/index.php cannot be decoded
    by this version of the ionCube Loader.
    If you are the administrator of this site
    then please install the latest version of the ionCube Loader.
    in Unknown on line 0

Scroll Up