WHMCS com PHP 8.1

0

A WHMCS.com divulgou no blog oficial que iniciou os testes com o PHP 8.1 após o anúncio do Ioncube Loader v12. Está previsto que entre 2-3 semanas seja lançado o WHMCS v8.6 (em versão beta).

Ioncube v12

É importante lembrar que o Ioncube Loader v12 é compatível apenas com PHP 8.1 e ambientes posteriores. O Loader anterior v11, suporta apenas até PHP 7.4. Isso significa que o WHMCS não será executado em ambientes PHP 8.0. Felizmente, o WHMCS v8.6 funcionará em ambientes PHP 7.2, 7.3, 7.4 ou 8.1 desde que você utilize o Loader v12.

Compatibilidade com PHP

O WHMCS v8.6 adiciona suporte para o ambiente PHP 8.1 enquanto mantém o suporte para os ambientes PHP 7.2, 7.3 e 7.4. A diferença entre PHP 7 e PHP 8 pode ser significativa e é por isso que estamos nos esforçando para tornar essa transição o mais suave possível para toda a comunidade WHMCS.

Compatibilidade em versões futuras

Esperamos que a v8.6 seja a última versão do WHMCS para suportar PHP 7 e que a próxima versão sem manutenção exigirá um mínimo de PHP 8.1.

PHP 8

Estamos nos esforçando para garantir que suas personalizações funcionem sem a necessidade de alterações funcionais. Dito isso, quando você está testando seu código no PHP 8, pode haver algumas pegadinhas. É altamente recomendável ler os guias de migração 8.0 e 8.1 para obter uma lista abrangente de preocupações, mas abaixo estão duas que vale a pena observar:

Compatibilidade de Tipo de Retorno com Classes Internas
Comparação de string para número Comparações

Resumo

A próxima versão, WHMCS v8.6, suportará as versões 7.2 a 8.1 do PHP (com exceção da 8.0) e prevemos que será lançada nas próximas 2-3 semanas.

Gostou? Comente!!!

DEIXE UMA RESPOSTA

Please enter your comment!
Please enter your name here